Ruby :Verによってエラーになるんだ

スポンサーリンク

Rubyist Magazine
http://magazine.rubyist.net/?0005-FirstProgramming

この記事がいつの記事かわかりませんがRuby-1.8.2-14_rc8の記事のようです。
わたしのRuby1.9.3

ここからダウンしたファイル動かすとこんなエラーが出ます。

 Snap_2013-7-14_16-57-14

Cannot load such file …

Snap_2013-7-14_17-33-11
これが悪いようです。

Snap_2013-7-14_17-33-22

このように、ファイル名の前に ./をつけるとエラーが消えました。

ググったサイト:

Rubyでrbファイルをrequireするときはドットを打つと良さそう
http://blog.ruedap.com/entry/20110531/ruby_require_load_path

コメント

タイトルとURLをコピーしました